Cursed Lands version 0.8.9

User avatar
grey_duck
Young scout
Posts: 15
Joined: Sat Dec 02, 2017 3:59 pm

Re: Cursed Lands version 0.8.8

Post by grey_duck » Mon Feb 12, 2018 6:27 pm

Yeah. I created a dark skinned dwarf in VN mode, and my pale skinned half-elf (normal) and elf (hard) both turned dark-skinned. Then I made a pale skinned human in easy mode, and everyone was back to normal. Then I played the VN character and everyone was dark-skinned again. So it's changing skin tones across saves/games.

User avatar
jack1974
Pack leader
Posts: 13921
Joined: Thu Jun 16, 2005 4:43 pm

Re: Cursed Lands version 0.8.8

Post by jack1974 » Mon Feb 12, 2018 6:41 pm

Well, this looks like a Ren'Py bug. I'll inform the coder about it, thanks :)
edit: actually no wasn't a bug in my code :lol: BTW wasn't only in VN mode, but in any mode. And not just the skin color (though probably that was the most noticeable effect), but all the values would replace the ones in the save.
This also explains a weird bug we had last month I think, when an user noticed the portrait being all corrupted (unaligned mouth/eyes/hair etc). So finally the mystery is solved! Thanks

User avatar
grey_duck
Young scout
Posts: 15
Joined: Sat Dec 02, 2017 3:59 pm

Re: Cursed Lands version 0.8.8

Post by grey_duck » Mon Feb 12, 2018 6:58 pm

Actually, I was the one with the corrupted portraits, and I was noticing that was back. So, yay! Solution eventually maybe coming!

User avatar
jack1974
Pack leader
Posts: 13921
Joined: Thu Jun 16, 2005 4:43 pm

Re: Cursed Lands version 0.8.8

Post by jack1974 » Mon Feb 12, 2018 7:48 pm

Yes on next update will work (but only starting a new game).

User avatar
grey_duck
Young scout
Posts: 15
Joined: Sat Dec 02, 2017 3:59 pm

Re: Cursed Lands version 0.8.8

Post by grey_duck » Wed Feb 14, 2018 5:16 pm

Stuck on day 10 in my current game. When I choose "End Day" the tips & tricks box pops up telling me to go to the Tomb of Urd. At the Orcish Wastes, my only option is to trade with the Dunemarchers.

User avatar
jack1974
Pack leader
Posts: 13921
Joined: Thu Jun 16, 2005 4:43 pm

Re: Cursed Lands version 0.8.8

Post by jack1974 » Wed Feb 14, 2018 5:23 pm

Another user reported that but didn't send me the savegame, can you send it? also, did you start this game with 0.8.8? in older version this bug was still present but shouldn't be in the latest one.
I think I can edit that event so that triggers only when you can actually explore the desert, I was a bit lazy with it :mrgreen: but if you have the save I can test if my idea works. Thanks

User avatar
grey_duck
Young scout
Posts: 15
Joined: Sat Dec 02, 2017 3:59 pm

Re: Cursed Lands version 0.8.8

Post by grey_duck » Wed Feb 14, 2018 5:31 pm

I sent you the save game anyway. I have no idea which version I started it in, to be honest. 0.8.6 maybe? There was that stretch where the updates were coming super fast, and I lost track.

User avatar
jack1974
Pack leader
Posts: 13921
Joined: Thu Jun 16, 2005 4:43 pm

Re: Cursed Lands version 0.8.9

Post by jack1974 » Wed Feb 14, 2018 5:50 pm

In any case it didn't matter, was something different, you ALREADY had done the orcish wastes quest :lol: so I added a check that if Nuala is already in your team, not bother to display that message. I tried with your save and was able to continue :)
I forgot to update the version number so you'll still see 0.8.9 but the game is updated also with yesterday's bugs (related to the portraits)

Mettii
Young scout
Posts: 2
Joined: Tue Feb 20, 2018 1:30 am

Re: Cursed Lands version 0.8.9

Post by Mettii » Tue Feb 20, 2018 1:37 am

This might be more of a Mac issue rather than an issue with the file, but it keeps on closing immediately upon launch. It never happens when I open older game apps from the folder, so I'm wondering what it could be. Is anyone else having problems with this? Autumn seems so far away and I really want to play this! :(

User avatar
jack1974
Pack leader
Posts: 13921
Joined: Thu Jun 16, 2005 4:43 pm

Re: Cursed Lands version 0.8.9

Post by jack1974 » Tue Feb 20, 2018 7:01 am

Yes unfortunately that seems a Mac issue. What MacOS version are you using? If it's very old that might be the problem :(

Post Reply