Page 1 of 1

Mac demo not working?

Posted: Fri Sep 16, 2016 10:33 am
by TigreBleu74

I downloaded the Queen of Thieves demo for Mac, and I tried to run the game to see if I liked it enough to buy the full version, but I can't get the demo to work.

When I click on the QoT application icon, the icon bounces around for about a full minute, as if the app was launching, but after the said minute, the app shuts down. Same goes for the README.html, forums.url and winterwolves.url files. They make the web browser icon bounce as if it was opening, but the browser fails to launch, usually after a minute or more spent hanging (spinning multi-colour wheel).

Any idea what could cause this problem?

Re: Mac demo not working?

Posted: Fri Sep 16, 2016 11:04 am
by jack1974
Uh that's new. Are you using the new MacOS perhaps?
When I tried here, it worked fine. It's especially strange that even the html/url files won't work, it's not possible :shock:
Maybe the .zip file was downloaded corrupted/incorrectly?

Re: Mac demo not working?

Posted: Fri Sep 16, 2016 6:39 pm
by TigreBleu74
I'm currently running on a MacBook Pro mid-2010 i5 with 8 GB RAM and a 256 MB VRAM video card. Operating under OS X 10.9.

I tried downloading the demo again, in case it was corrupted as you suggested. Same results, though: game hangs and shuts down. The usual window asking if I want to open the file since it was downloaded from a third party (i.e., not Apple) developer doesn't even appear.

As you stated, the .url and .html files should work fine. Guess it's an OS issue on my side. I'll see if I can solve the issue and I'll try running the app again afterwards.

Thanks for the help, though. Much appreciated. :)

Re: Mac demo not working?

Posted: Fri Sep 16, 2016 6:41 pm
by jack1974
Ah yes then it's some uncommon behavior. I have tried again here and worked, it showed the warning message "OMG are you sure you want to open this app downloaded from internet!?!?" :lol: and then it worked.
But yeah, url are simple text files, so it's not possible that they don't work :)

Re: Mac demo not working?

Posted: Sat Sep 17, 2016 2:13 am
by TigreBleu74
I tried to reboot, to repair the HDD authorizations and to repair the HDD, to no avail. Then I rebooted, and it suddenly worked normally. Guess I just needed to clean my memory more than once to make it work.

So far, the demo looks really fun. And the three girls—especially the young thief—are just lovely. :)