Page 1 of 1

Equipping Gems

Posted: Mon Aug 08, 2016 1:22 pm
by Alex81

I just realized most the fights in the game (so far) have been rather difficult.
This again boiling down to, me not quite having gotten how to do one equip gems in armour.

I started anew to run the tutorial once more, your father explaining you can equip certain gems to improve your armour/weapon.
I -did- click the armour, and got to the screen with the gems and slots and all ...but...

Even if I click the gems there, and then the unused slots (tried on different suits of armour) ...they just don't move over to the slot.
Even if I do try to click confirm. Is there some trick to equipping gems (requirements) I'm just too blind to see?

Re: Equipping Gems

Posted: Mon Aug 08, 2016 2:11 pm
by jack1974
I am not sure what you're doing wrong :shock: I just tried to restart a new game (just in case the new update messed up something) but I was able to socket the initial tutorial gem just fine. Are you using the latest version ? also are you clicking the gem/slot? not DRAGGING the gem :)

Remember: the weapons don't use gems, only the armors. But that's not an issue since if you double click the weapon a messagebox will pop up to explain this :)

Re: Equipping Gems

Posted: Mon Aug 08, 2016 10:00 pm
by Alex81
I -finally- found the problem :)

I clicked the gem, and then, the box/bracked below saying "Empty Socket" (It even lights up! :D)
Nothing happened.....until I noticed the two slots to the -left- of the gem window. I completely failed to see those slots
as I focused too much on the boxes saying "empty socket 1 and empty socket 2"
Thanks for the help (and sorry)