Can't seem to get the demo to run

Life simulation game in a fantasy world: http://www.winterwolves.com/spiritedheart.htm
Post Reply
wtwtwtwt
Young scout
Posts: 3
Joined: Sun Apr 18, 2010 12:42 am

Can't seem to get the demo to run

Post by wtwtwtwt » Sun Apr 18, 2010 12:50 am

Downloaded the demo to try the game - but it won't run.

The game installs but when I actually try to run it nothing happens. The little green busy symbol appears on the arrow cursor and I can hear the computer making harddrive access noises, but nothing ever pops up on screen. The program pops up in the processes tab of the task manager for a few seconds before disappearing.

I have windows 7 64 bit.

User avatar
jack1974
Pack leader
Posts: 14489
Joined: Thu Jun 16, 2005 4:43 pm

Re: Can't seem to get the demo to run

Post by jack1974 » Sun Apr 18, 2010 6:53 am

Uhm, that's weird - I know many people that can run it just fine on W7 (not sure about 64-bit).
Do you have one of those netbooks perhaps? weird screen size?

wtwtwtwt
Young scout
Posts: 3
Joined: Sun Apr 18, 2010 12:42 am

Re: Can't seem to get the demo to run

Post by wtwtwtwt » Sun Apr 18, 2010 10:47 am

jack1974 wrote:Uhm, that's weird - I know many people that can run it just fine on W7 (not sure about 64-bit).
Do you have one of those netbooks perhaps? weird screen size?
No, it's a desktop computer. Screen resolution is currently 1600 x 1200.

I have an Intel Core I5 CPU, is there any other hardware that might be relevant?

User avatar
jack1974
Pack leader
Posts: 14489
Joined: Thu Jun 16, 2005 4:43 pm

Re: Can't seem to get the demo to run

Post by jack1974 » Sun Apr 18, 2010 11:17 am

Ah no, it's definitely not the screen size then! :)
I think it might be some sort of permission problem. The game even uses software rendering, so the video card has no relevance in this. Just a stupid idea, but have you tried uninstalling it, redownloading it (or another of my games) to see if works? At the moment I can't think about anything, usually if any Renpy (the tool I used to make it) game crashes, would show a text message. The fact that it doesn't display anything on screen is really weird!

User avatar
jack1974
Pack leader
Posts: 14489
Joined: Thu Jun 16, 2005 4:43 pm

Re: Can't seem to get the demo to run

Post by jack1974 » Sun Apr 18, 2010 4:09 pm

Got some hints from Renpy author himself:
I'd also look for traceback.txt, error.txt, or renpy.log files in the directory with the .exe in it
so please check if you see any of those files and post here their contents (should be some error message explanation).

wtwtwtwt
Young scout
Posts: 3
Joined: Sun Apr 18, 2010 12:42 am

Re: Can't seem to get the demo to run

Post by wtwtwtwt » Tue Apr 20, 2010 10:08 pm

jack1974 wrote:Got some hints from Renpy author himself:
I'd also look for traceback.txt, error.txt, or renpy.log files in the directory with the .exe in it
so please check if you see any of those files and post here their contents (should be some error message explanation).
Unfortunately none of those files seem to have been generated.

I checked out a few other games from the renpy site and they work on my computer.

I dunno. Oddness.

With no error messages or debug logs of any kind to work with, I don't expect there is much we can do about it. Thanks for the help regardless though.

User avatar
jack1974
Pack leader
Posts: 14489
Joined: Thu Jun 16, 2005 4:43 pm

Re: Can't seem to get the demo to run

Post by jack1974 » Fri Apr 23, 2010 7:46 am

Heh unfortunately seems like 1 in a million case. I know nobody else who couldn't run the demo of that game, sorry.

kashre
Young scout
Posts: 1
Joined: Mon Oct 25, 2010 9:17 am

Re: Can't seem to get the demo to run

Post by kashre » Mon Oct 25, 2010 9:25 am

just thought Id mention I'm having the exact same problem. Running the demo in administrator mode, it just fails to start. No error messages, no log files relating to a crash. I'm also using Win 7 x64

User avatar
jack1974
Pack leader
Posts: 14489
Joined: Thu Jun 16, 2005 4:43 pm

Re: Can't seem to get the demo to run

Post by jack1974 » Mon Oct 25, 2010 10:44 am

Ah I found out the problem! It happens only with x64 versions of windows (so even XP, doesn't matter if you have XP/Vista/V7).
The fullversion is fixed, as for the demo for now I uploaded a test version here:
http://www.didone.com/games/SpiritedHeartTrial.exe
can you please download it and let me know if works (it should now). Thanks

Post Reply