Desktop Mobile Forums Blog Support Patreon

Comments on vers 1.03

A space strategy macromanagement game with turnbased battles.
biff
Young scout
Posts: 12
Joined: Mon Jun 23, 2008 1:37 am
Location: Toronto

Comments on vers 1.03

Postby biff » Wed Aug 20, 2008 6:53 pm

Well I've played a game or two of the latest version and I have to say that I'm very impressed with the improvements, fixes and the new stuff. I do have a few comments (of course) :)

1 - In battle it seem that ships that are near the left or right side of the screen are not selectable. This "dead" area seems to be the same as the area that the ship info panel appears in. I can usually fix this by scrolling until the ship is closer to the centre of the screen but it's still a bug I think. I've also noticed that when this happen the text at the top left and right of the screen disappears too.

2 - It seems that some of my ships aren't available in subsequent battles during the same turn. This happened in the previous version of the game as well but I don't know why.

3 - The "Next" button in the ship selection/placement phase is disabled when you don't have enough ships to need it - which is great - but it is still active when there are only 8 ships. A small point I know.

4 - I haven't tried the custom ships yet as I wanted to work through a game first but I ran into enemy scouts with 40 crew. This seems a bit much since even cruisers don't have that much crew. Perhaps a few adjustments are necessary? This makes the transports less important to strategy if the enemy ships are so hard to take over and is quite a difference from the previous version.

5 - I'd still like to see a mini-map of the whole star system in the battle screen.

6 - Auto turn advance stops after I've been attacked but doesn't seem to stop after I finish a battle I start. Shouldn't this be consistent?

7 - I'd still like the galaxy map to fit to the whole screen rather than having to scroll to see the last 10% of it.

8 - I think it would be a good idea to have direct access via the keyboard to the 6 menus at the bottom of the screen (Resources, Military, Galaxy map, Ship design, Tech, Stats) Perhaps these could be assigned to the key of the first letter of each menu (R, M, G, S, T - not sure what to do about stats though). It would save mousing around as I often find myself jumping from the Galaxy Map to the Military screen.

9 - I still find the spinning text at the start of each battle turn to be too long. The timing of the voice over is good so I suggest just having the text appear in the normal way but have it fade out quickly as the voice over stops rather than having it spin out.

10 - The "End Turn" button is still overlaid on the battle screen and ships can move under it. This means there is still the danger of accidentally ending a turn when trying to move a ship.

11 - There seems to be an even longer gap between when a target is attacked and when the attack actually happens on the screen (when the missiles start firing). Is there any way to speed this up?

12 - After about 2 hours of play my game locked up and I had to force quit, loosing all my progress. Is there anyway to set and auto save in order to help solve this?

13 - In the previous version I sometimes ended up with captured enemy ships in my fleet in subsequent battles. It was never all the ships I had captured and they seemed to have less movement - which makes sense to me - and I think this is a good idea. However in this version I was getting enemy ships that I had never captured in the first place added to my available ships. This happened several times with several different types of enemy ships.

14 - In the ship placement phase at the start of a battle there was an enemy ship BEHIND the green lines of starting spaces. Is this normal?

Thanks again for all the updates and improvements. I'm still having fun with it.

biff
Young scout
Posts: 12
Joined: Mon Jun 23, 2008 1:37 am
Location: Toronto

Re: Comments on vers 1.03

Postby biff » Thu Aug 21, 2008 2:34 am

My comments above were all playing the Blood Legion faction. I've just started a game playing the Blue Army faction and I've had a few odd things happen.

Firstly when building ships and selecting to build a scout (for example) any scouts that I already have at 100% on the military screen go down to lower percentages and need to get built up again before the new ship gets built. This problem happened in the beta version. I didn't have this issue playing the Blood Legion but it happened almost right away playing the Blue Army.

Secondly the problem that I noted above concerning how not all my ships are available for the next turn is even worse playing the Blue Army. It seems that even ships that survive a battle don't remain in my fleet for the next battle or even the next turn.

I had the game check and it tells me that I am playing the latest build.

User avatar
jack1974
Pack leader
Posts: 12495
Joined: Thu Jun 16, 2005 4:43 pm

Re: Comments on vers 1.03

Postby jack1974 » Thu Aug 21, 2008 7:15 am

Hm does this happen even if you quit the game completely and start a new game ? let me know, if is that then probably need to clear some variables if you start a new game without exiting a old one :oops:

biff
Young scout
Posts: 12
Joined: Mon Jun 23, 2008 1:37 am
Location: Toronto

Re: Comments on vers 1.03

Postby biff » Fri Aug 22, 2008 8:16 pm

Well I only every play one game at a time even if I save and quit from day to day. I'm not sure if that helps or not. Maybe it only happens if I have an old, completed game in the save slot. In my current game - where I first noticed this problem I would have had the last save of the previous (and completed) game in the save slot. Now that I have played the current game a bit and have saved it in the same slot I don't seem to be having the problem. I'm not sure if this is related but it could be I guess based on your post.

User avatar
jack1974
Pack leader
Posts: 12495
Joined: Thu Jun 16, 2005 4:43 pm

Re: Comments on vers 1.03

Postby jack1974 » Sat Aug 23, 2008 2:08 pm

Hm yes could be related indeed. Maybe you were using a old savegame from a version prior to 1.0.3 ?

biff
Young scout
Posts: 12
Joined: Mon Jun 23, 2008 1:37 am
Location: Toronto

Re: Comments on vers 1.03

Postby biff » Wed Aug 27, 2008 3:15 am

It wasn't a saved game from an older version but, having done a bit more testing with a new game, I think it happens when a previous game from the current version has been saved and a new game is started. The problem seems to continue until the new game has been saved over the old game. I had the problem happen again a few days ago where all of a sudden I had 3 enemy transports in my ship inventory during the placement phase. I hadn't even encountered that ship type in the game yet so it was a real surprise to find them in my available ships. Perhaps if someone always plays the same faction this issue isn't as obvious but since I have been alternating factions each game it becomes more apparent when ships suddenly appear on the list.

User avatar
jack1974
Pack leader
Posts: 12495
Joined: Thu Jun 16, 2005 4:43 pm

Re: Comments on vers 1.03

Postby jack1974 » Wed Aug 27, 2008 5:19 am

Ah interesting, will investigate it, thanks for the feedback! :oops:


Return to “Supernova 2: Spacewar”

Who is online

Users browsing this forum: No registered users and 1 guest